Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Grüne Klötze - Ursachen und Abhilfe (bish. Hoffn. auf Hilfe)
#11
Ich habe wieder mal ein bißchen nachgedacht. Ich glaube nicht, daß mit dem Ändern der VBV-Puffergröße das Problem wirklich gelöst wird. Es könnte aber sein, daß der Mustek tatsächlich mit der Puffergröße nicht klarkommt (vielleicht rundet er tatsächlich aufs Vielfache von 16 ab) und daß das mit dem Problem der anderen überhaupt nichts zu tun hat.

Ich habe inzwischen mit VobEdit die GOP-Header vonVob-Dateien aus Sendern mit VBV 91 mit solchen aus Sendern mit VBV 112 verglichen. Da ist mir aufgefallen, daß der VBV-Delay bei beiden gleich ist. Deshalb glaube ich nicht, daß der VBV-Delay das Problem ist. Mir ist aber auch noch etwas Anderes aufgefallen:
Bei den Vobdateien mit VBV 91 kommt nach der Sequence Header Extension (oder so ähnlich) noch eine Sequence_Display_Extension, aber bei denen mit VBV 112 nicht. Wer weiß, vielleicht haben wir mit der VBV-Größe nur das falsche Ende einer heißen Spur verfolgt, und es ist gar nicht die VBV-Größe, sondern diese zusätzliche Sequence_Display_Extension.
Übrigens waren die Sender mit VBV 91 ARD und Super RTL, und die mit VBV 112 waren Kinderkanal, Tele5 und Boomerang. Ich werde dies noch mit anderen Sendern verfolgen.

Für mich stellt sich jetzt erst mal die Frage, ob man die Sequence_Display_Extension einfach rausschmeißen kann, und wie man das machen kann: Ob man dann noch andere Längen und Startadressen ändern muß, ob man am Ende des Pakets Nullbytes einflicken soll, oder ob man für den Sequence_Display_Extension-Block einfach etwas Anderes Gleichlanges einsetzen soll, das keine Bedeutung hat.

Gerade habe ich ReStream entdeckt, das da möglicherweise helfen kann.

Richard Schmidt.
Zitieren
#12
Hallo,
diesen Überlegung hatte ich auch schon, mit restream Idea einfach
die SDE zu löschen. Hat aber nichts gebracht. :evil:

Scheinbar ist der DVB Stream von besagten Sendern in der GOP-Struktur
für manche SA-Player nicht mehr dekodierbar bzw. entstehen Überläufe
oder Synch-Probleme beim Dekodieren, sodaß sich das in der Anzeige
auswirkt (grüne Klötzchen)

Bei weiteren Möglichkeiten der Ursache bin ich noch auf Gemeinsamkeiten
gestoßen: alle Player mit dem Problem (meistens Toshiba aber auch Samsung) haben Zoran Vaddis Dekoder eingebaut. Der scheint
sehr DVD-konform zu sein -- will sagen der ist scheinbar nicht so "gutmütig" wie andere SA-Player.
Gruß
KSTROE
Zitieren
#13
was passiert, wenn ihr die Bitrate (z.B. bei ARD/RTL) auf z.B. fixe 8Mbps für alle GOPs setzt, incl. VBV buffer auf '112' und vbv_delay '0xFFFF' ... , alles vor dem Muxen.

insbes. wenn die Fehlstellen 'willkürlich' übers ganze Bild verteilt zu sein scheinen.

vergleichsweise kann man mit der Einzelbildschaltung im SA und PC evtl. eine solche Szene lokalisieren zur weiteren Analyse.
Zitieren
#14
Hallo,
habe gerade eine DVD mit den vorgeschlagenen Einstellungen
gebrannt. << bitrate value in first sequence >> habe ich einmal auf
"keep original" und einmal auf <=9,8Mbps gesetzt.
An den Einstellungen habe ich auch schon probiert. Das Ergebnis ist
immer das gleiche egal was dort für Einstellungen
gemacht werden .... grüne Artefakte (Klötzchenbildung)

Die Fehlstellen sind dabei, so meine ich, immer gleich und zwar immer
dort wo viel Bewegung im Bild ist, bei Szenenwechsel, also kompletter
Neuaufbau des Bildes, ist alles grün, auch wenn man das Bild dann einfriert - Standbild.
Am PC ist davon nichts zu sehen (Powerdvd SofDVD Player) :?:

hier noch ein Auszug aus MPG2schnitt vom Sequenzheader:
mit 8Mbps Einstellungen und vbv= "112" vbv-delay=max

Sequenzheader:
Bildbreite: 720
Bildhöhe: 576
Seitenverhältnis: 3/4
Framerate: 25 Bilder/sek.
Bitrate: 8 MBit/sek.
VBV-Puffer: 224 KByte
Profil/Level: Main/Main
Farbformat: 4:2:0
Low Delay: Nein
------------------------------------
Bildheader:
Bildtyp: I-Frame
DC Prezision: 8
Bild Struktur: Frame
oberstes Bild zuerst: Ja
------------------------------------
Audioinformationen
Mpeg 1 Layer 2
Bitrate: 192 KBit/sek
Samplerate: 48000 Hz
Channel Mode: Stereo
Gruß
KSTROE
Zitieren
#15
Hallo,

der Vollständigkeithalber hier auch noch die quickinfo von projectx
(gehört vielleicht auch ins projectx-forum) also nur zur Info

=> File 0: K:\test.rec (130426880 bytes)

=> File is DVB/MPEG-2 TS (Video/Audio/TTX PES)

=> demux

-> SID 0x6DCA

-> PMT 0x64 refer to these Video/Audio/Text related PIDs :

< 0x65 0x66 0x68 >

!> missing sync. byte @ 0

!> found sync. byte @ 1692

ok> PID 0x68 has PES-ID 0xBD (private stream 1) (TTX) (0x1A70 #28)

ok> PID 0x65 has PES-ID 0xE4 (MPEG Video) (0x6268 #126)

ok> PID 0x66 has PES-ID 0xC0 (MPEG Audio) (0xA24C #213)

--> PID 0x0 (PAT or others) (0x138D8 #418) -> ignored

--> PID 0x64 (PMT) (0x185F4 #523) -> ignored

-> video basics: 720*576 @ 25fps @ 0.6735 (4:3) @ 1490800bps, vbvBuffer 91

-> starting export of video data @ GOP#0

!> dropping useless B-Frames @ GOP#0 / new Timecode 00:00:00.000

packs: 27758 4% 5242944

video: fr/ct/1p/cg/og/dg 250/1/0/21/0/0

videolength: 250f @ 00:00:10.000

avg. nom. bitrate 3369478bps (min/max: 2236000/5043600)

===> new File: F:\videos\schnitt\test.m2v

--> Teletext on PID 0x68 (SubID 0x10)

--> MPEG Audio (0xC0) on PID 0x66

Audio PTS: first packet 10:54:32.377, last packet 10:54:42.865

Video PTS: start 1.GOP 10:54:32.858, end last GOP 10:54:42.858

-> adjusting audio at video-timeline

!> missing syncword @ 0, @ 00:00:00.000

!> found syncword @ 432

=> src_audio: MPEG-1,Layer2,48000Hz,stereo,192kbps,CRC @ 00:00:00.000

audio frames: wri/pre/skip/ins/add 417/0/0/0/0 @ 00:00:10.008 done..

===> new File: F:\videos\schnitt\test.mp2



summary of created media files:

.Video: 250 Frames 00:00:10.000 F:\videos\schnitt\test.m2v

Audio 0: 417 Frames 00:00:10.008 0/0/0/0 F:\videos\schnitt\test.mp2

=> 4452040 bytes written...

--- end of quick info ---
Gruß
KSTROE
Zitieren
#16
Mir sind im header der streams ein paar unterschiede aufgefallen, zdf geht bei mir einwandfrei, super rtl mit grünen klötzchen.
Ich habe das tool und zwei screenshots angehängt, vielleicht können die profis damit was anfangen.

mfg drogon


Angehängte Dateien
.rar   stream.rar (Größe: 51,74 KB / Downloads: 417)
Zitieren
#17
Vielen Dank für die Versuche und Ergebnisse.
Dann hilft also offenbar weder das Setzen der VBV-Puffergröße noch das Entfernen der Sequence Header Extension.
Ich habe jetzt mal meine alten DVDs (von vor einem halben Jahr) mit VobEdit untersucht und entdeckt, daß bei BR-Alpha, Bayerischem Fernsehen, Hessen-Fernsehen und Südwest-Fernsehen damals die VBV-Größe 112 war. Bei BR-Alpha und Bayerischem Fernsehen war sie zwischendurch auch mal 109 (Anfang Dezember 2003). Vielleicht hat ja jemand, bei dem sich Klötze zeigen, eine ältere gebrannte Aufnahme von einem dieser Sender, dann würde ich ihn bitten, es mal auszuprobieren, ob die Fehler da auch schon gekommen sind.
RBB Berlin hatte schon im Oktober VBV 91.
Ich kann mir nicht vorstellen, daß alle Sender, die mit VBV 112 senden, ganz DVD-konform senden, und alle Sender, die mit VBV 91 senden, ganz unkonform senden. Deshalb glaube ich eher, daß es eine andere Ursache haben muß.
Vielleicht kann ich bei der BR-Zuschauerredaktion etwas erfahren.
Man sollte herausfinden, ob die Fehler zuverlässig immer bei Sendern mit VBV 91 auftreten und zuverlässig nie bei Sendern mit VBV 112 auftreten.
Hat jemand gegenteilige Erfahrungen gemacht?
Richard Schmidt.
Zitieren
#18
@kstroe
Lassen sich die Problemstellen auf Szenen mit nicht-DVD konformen überlangen GOPs zurückführen? (die beim Neukodieren ja IMO nicht erzeugt werden)
evtl. läßt sich präzise die Bildnummer über den Inhalt feststellen, bei dem der Effekt eintritt.

P7 hat diese aber auch und ist wohl aufm Toshi nicht problematisch, oder?
Zitieren
#19
@dvb.matt

Ich habe die Vermutung, daß es so ist, nur kann ich beim besten Willen
keinen Unterschied zwischen einem Stream von SAT1 (der läuft auf Toshi)
und einem Stream von RTL entdecken.
Nach mpgaz beginnen beide Streams mit einer closed GOP danach
sind die GOP´s bei beiden Streams nicht geschlossen.
(closed GOP-Flag = 0 - Ich hoffe meine Vermutung ist richtig)
Die I-P-B Frames sind in der Anzahl auf 12 oder weniger beschränkt.
Die nächste Struktur bezieht sich aber noch , wenn ich richtig verstanden
habe, auf die vorherige usw. da closed GOP=0 oder :?:

Im Toshi beginnt schon das erste Bild mit Artefakten, als ob er sich
falsch synchronisiert. Es kommt vor, das ein Bild richtig angezeigt wird nur welches das jetzt in der GOP-Struktur ist, dazu fehlt mir die Erfahrung oder Mittel. Also ist es genau umgekehrt: es wird so gut wie kein Bild richtig angezeigt.
Bei schnellem Vorlauf entstehen keine Artefakte.

Mit P7 habe ich noch nicht probiert. Vermute aber das gleiche Resultat
vbv 91 - Klötzchen, vbv 112 - ok auch wenn es damit wahrscheinlich gar nichts zu tun hat.
Gruß
KSTROE
Zitieren
#20
Wenn man herausfinden könnte, bei welchem Bildtyp die Klötzchen auftreten, so könnte das sehr weiterhelfen.
Ob es sich um ein I, P- oder B-Bild läßt sich leicht mit Mpeg2Schnitt feststellen, denn der Bildtyp wird für jedes Bild angezeigt. Auch das Navigieren bildweise, GOP-weise (d.h. zum nächsten / vorigen I-Frame) oder zum nächsten/vorigen Bild, das kein B-Frame ist, ist damit sehr einfach. Allerdings muß man vorher den Film demultiplexen.
Es stimmt. Bei den meisten GOPS gehören die ersten beiden Bilder (B-Frames), die nach dem I-Frame übertragen werden, noch zur alten GOP. Aber auf dem Spieler werden die beiden B-Frames vor dem I-Frame gezeigt. In dieser Reihenfolge werden sie auch von Mpeg2Schnitt wiedergegeben.
Wenn das stimmt, daß alle Sender, die mit VBV 112 senden, keine grünen Klötze bringen, dürften überlange GOPS kein Problem sein, denn auch bei diesen Sendern werden von PVAStrumento jede Menge überlange GOPS gemeldet. Beim Kinderkanal sind es jedenfalls sehr viele.

Für die nächste Zeit habe ich folgendes vor (ich weiß aber nicht, ob ich die richtigen Adressen finde):
1.) Bei SES/Astra fragen, ob die mir sagen können, was sich bei der Umstellung von VBV 112 auf 91 geändert hat.
2.) Beim Hersteller des Zoran-Decoders fragen, ob die eine Ahnung haben, woran das liegen könnte und was man dagegen versuchen könnte.

Andere Ideen habe ich im Moment nicht. Aber vielleicht gelingt es mir, die mit rar komprimierten Informationen von Drogon herunterzuladen und zu dekomprimieren, und vielleicht fällt mir ja dann was auf.

Übrigens, auch wenn ich manchmal recht gescheit daherrede, so habe ich doch von MPEG nicht viel Ahnung. Ich versuche nur, das Wenige, was mir aufgefallen ist, auch anderen mitzuteilen. Es tut mir leid, wenn ich die Hoffnung geweckt habe, daß mit einem kleinen Programm, das die VBV-Größe ändert, das Problem beseitigt ist, aber das habe ich tatsächlich geglaubt.

Richard Schmidt.

Richard Schmidt.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Hilfe ich bin (fast) am verzweifeln jackn 2 4.227 11.05.2011, 20:43
Letzter Beitrag: jackn
  Bitte Hilfe: DVB Stream für DVD konvertieren (aus: "Halbbilder verschoben") Skeeve 14 7.087 19.10.2009, 13:08
Letzter Beitrag: Syncroniza
  Anfänger braucht Hilfe - ProjektX -> M2S -> GfD antl83 6 3.621 08.08.2008, 21:33
Letzter Beitrag: antl83
  Tonverbesserung nach Videoaufnahme - Hilfe! ComeOnKiki 2 2.848 29.07.2008, 00:52
Letzter Beitrag: hagge
  Hilfe - GUI for dvdauthor braucht Stunden! Robin 2 1.603 04.04.2007, 17:02
Letzter Beitrag: Robin
  Breuchte dringend hilfe zum thema schneid. bitmaster2k 4 1.892 19.01.2006, 18:02
Letzter Beitrag: akapuma
  Video Bearbeitung: Hilfe für einen Neuling marfra 2 7.634 04.01.2005, 14:19
Letzter Beitrag: marfra
  "Grüne Klötzchen" - Bei welchen Sendern ? HOSTess 16 4.000 17.11.2004, 09:19
Letzter Beitrag: RchdSchmidt
  Fehler meldung SpruceUp, Hilfe !!!!! curo 2 1.777 11.02.2004, 17:06
Letzter Beitrag: skl
  Brauche Hilfe bei TmpegEnc CatbullMK 7 2.475 08.01.2004, 10:32
Letzter Beitrag: CatbullMK

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste