Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Version 0.9.4 (Fehler, Hinweise, Fragen usw. bitte nur hier posten)
#31
Hallo,

M2S ist ein 32-Bit Programm und es stammt aus einer Zeit zu der DirectX 7 zwar nicht mehr ganz neu aber auch noch nicht hoffnungslos veraltet war. Es genügt nicht wenn eine DDRAW.DLL vorhanden ist, es muss auch noch eine sein die die verwendeten Funktionen zur Verfügung stellt. Ist das nicht der Fall kommt es zu dieser Fehlermeldung.

Ich selbst habe mich schon vor einigen Jahren von Windows verabschiedet. WinXP läuft nur noch in einer VirtualBox für M2S. Ich kann also zu neueren Windowsen nichts sagen.

Ich sehe zwei Möglichkeiten. Zum einen würde ich eine DDRAW.DLL von einem Rechner auf dem M2S läuft in das Verzeichnis von M2S kopieren. Wenn das nicht hilft bleibt noch eine virtuelle Maschine mit WinXP.

Martin
[KNC One TVStar/ P2 400MHz/ Ubuntu] [DVBStream] [TS/MPV-MP2-AC3][ProjektX/ M2S/ GfD]
Zitieren
#32
Martin schrieb:Hallo,

M2S ist ein 32-Bit Programm und es stammt aus einer Zeit zu der DirectX 7 zwar nicht mehr ganz neu aber auch noch nicht hoffnungslos veraltet war. Es genügt nicht wenn eine DDRAW.DLL vorhanden ist, es muss auch noch eine sein die die verwendeten Funktionen zur Verfügung stellt. Ist das nicht der Fall kommt es zu dieser Fehlermeldung.

Ich selbst habe mich schon vor einigen Jahren von Windows verabschiedet. WinXP läuft nur noch in einer VirtualBox für M2S. Ich kann also zu neueren Windowsen nichts sagen.

Ich sehe zwei Möglichkeiten. Zum einen würde ich eine DDRAW.DLL von einem Rechner auf dem M2S läuft in das Verzeichnis von M2S kopieren. Wenn das nicht hilft bleibt noch eine virtuelle Maschine mit WinXP.

Martin

Danke für die Info Martin. Es ist so, dass unter Win 8 das ganze noch problemlos funktionierte, aber unter Win 8.1 nicht mehr. Egal welche DDRAW.dll verwendet wird, es erscheint immer dieselbe Fehlermeldung.
So muss ich mir eine andere Lösung suchen.

Trotzdem vielen Dank Euch allen!!!
Zitieren
#33
Theoretisch sollte dein vorhandenes DirectX 11 abwärtskompatibel sein, aber da es nicht funktioniert, versuch mal, ob du DirectX 9.0 zusätzlich installiert bekommst (da ist auch DirectDraw mit drin, das Mpeg2Schnitt auf jeden Fall unterstützt).
Es gibt dafür einen Web Installer von Microsoft:
http://www.microsoft.com/de-de/download/...aspx?id=35
Dieser Web Installer sollte die für dein System passenden Komponenten installieren.

Ich selber kann es auch nicht probieren, da ich um Windows 8.x einen riesen Bogen drum mache....
Lostech
Zitieren
#34
Lostech schrieb:Theoretisch sollte dein vorhandenes DirectX 11 abwärtskompatibel sein, aber da es nicht funktioniert, versuch mal, ob du DirectX 9.0 zusätzlich installiert bekommst (da ist auch DirectDraw mit drin, das Mpeg2Schnitt auf jeden Fall unterstützt).
Es gibt dafür einen Web Installer von Microsoft:
http://www.microsoft.com/de-de/download/...aspx?id=35
Dieser Web Installer sollte die für dein System passenden Komponenten installieren.

Ich selber kann es auch nicht probieren, da ich um Windows 8.x einen riesen Bogen drum mache....

Hallo Lostech,

danke für diesen Tip - er lässt es leider nicht installieren da schon eine neuere Version installiert ist.

Ich habe eher per Zufall die Version 0.9.3 installiert. Jetzt kann ich wieder das Video sehen und schneiden. Aber die Schnittvorschau funktioniert nicht mehr. Es öffnet sich ein neues Fenster in dem steht es werden beide Schnitte zusammengerechnet, aber dieses schliesst sich wieder ohne dass ich die beiden zusammengefügten Schnitte sehe. Kennt Ihr dieses Problem? Ich verwende die Standardeinstellungen von MPEG2Schnitt.

Und ist es üblich, dass in Version 0.9.3 dieser Bildschirm erscheint, wenn das Schneiden angestossen wird?
   
Danke für Eure Hilfe
Maschendrahtman
Zitieren
#35
Der Bildschirm ist das SchnittTool. Martin hat die Schneideroutinen in dieses Tool ausgelagert. Man muß sich normalerweise nicht drum kümmern.

Testweise kannst Du ja mal unter Optionen - Video/Audioschnitt - Videoschnitt das Häkchen bei "Framegenau schneiden" entfernen, und gucken, was passiert.

Gruß

akapuma
Zitieren
#36
Hallo Martin,

vorab, vielen Dank für Dein tolles Program. Beim Muxen der geschnittenen Dateien habe ich festgestellt, dass z.B. mplex für gewisse Einstellungen die maximale Bitrate der zu muxenden Video-/Audiostreams und die Decoder-Puffergröße braucht (siehe dazu http://forum.dvbtechnics.info/showpost.p...ostcount=3), aber anscheinend nicht selbst berechnen kann.

Da - wenn ich es recht verstehe - Mpeg2Schnitt die maximale Bitrate bereits berechnet/ermittelt und die Puffergrößen in den Video-/Audiostreams enthalten sind, wäre es hilfreich, wenn diese Werte von Mpeg2Schnitt als Parameter ausgegeben werden würden und so in den Mux-Scripten verwendet werden könnten.

Wäre es möglich diese Ausgabe in der nächsten Version von Mpeg2Schnitt zu implementieren?

Viele Grüße

McDummy
Zitieren
#37
Hallo McDummy,

schau mal ob hier schon bei ist was du suchst.
http://www.mdienert.de/mpeg2schnitt/Foru...ablen.html

Martin
[KNC One TVStar/ P2 400MHz/ Ubuntu] [DVBStream] [TS/MPV-MP2-AC3][ProjektX/ M2S/ GfD]
Zitieren
#38
Hallo Martin,

vielen Dank für die Antwort. Die Variablenliste hatte ich mir schon vor meinem Post angesehen.

Wenn ich es recht verstehe, würden die Variablen $Bitrate# und $VBVPuffer# in der Tabelle Videoeigenschaften und $Bitrate# in der Tabelle Audioeigenschaften den benötigten Werten am nächsten kommen.

Jedoch ist mir nicht klar, ob diese Werte bereits ausreichen, oder ob ich auf diese Werte in den Mux-Scripten, also in der Nachbearbeitung, zugreifen kann.

Für Mplex bräuchte man die Summe der maximalen Video-Bitrate und der Bitraten der zu muxenden Audiostreams (und eventuell die Summe der einzelnen Puffer). Auch wird auf einigen Seiten empfohlen für Mplex zusätzulich noch 2% der Summe zu addieren, um den Mplex overhead zu berücksichtigen.

Wenn ich die Scripte recht versteh, kann man diese $Bitrate#-Werte im Script nicht addieren. Zusätzlich sollte die $Bitrate#-Variable dann auch nach Video und Audioströme unterscheidbar sein, z.B. $Video-Bitrate#, $Audio1-Bitrate#...

Da die Bitrate des Videos aus dem 1. Header (des ursprünglichen Datei oder der geschnittenen?) ermittelt wird, ist dort auch unter umständen nicht der maximale Wert gesetzt.

Viele Grüße

McDummy
Zitieren
#39
habe ein frage
wenn ich 16:9 filme lade in mpeg schnitt sehe ich nciht die original grösse
und die bilder die daraus mache sind gestaucht
gibt es da was damit das nicht ist
grüsse
isabeck
Zitieren
#40
Entweder in den "Video/Audioschnitt" Optionen den Header auf "Aspectratio 9/16" umstellen und dann die Filmdaten neu laden oder die Filmdaten vor dem Laden auf 16:9 patchen (z.B. mit dem DVD Patcher).
Lostech
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Ich brauche bitte Hilfe: Nachbearbeitung six..pack 0 2.309 06.09.2014, 03:52
Letzter Beitrag: six..pack
  Aktuelle Version McDummy 5 3.274 12.04.2013, 08:19
Letzter Beitrag: McDummy
  Version 0.9.2 (Fehler, Hinweise, Fragen usw. bitte nur hier posten) Martin 52 25.952 21.01.2010, 22:16
Letzter Beitrag: Martin
  Version 0.9 (Fehler, Hinweise, Fragen usw. bitte nur hier posten) Martin 108 40.057 06.12.2009, 15:52
Letzter Beitrag: kassandro
  plötzlich Fehler nach langer Anwendung hafly 4 2.583 14.07.2009, 10:34
Letzter Beitrag: hafly
  Fehler -113122 bei "Black Video" bei NeroVision NTSC clip Cela 2 1.863 28.02.2009, 20:16
Letzter Beitrag: Cela
  Fehler beim video fadeout mit mpeg2schnitt: -113523 jon 16 4.949 23.02.2009, 02:24
Letzter Beitrag: jon
  Bitte um Hilfe - AC3 kein Ton über FFDShow in Mpeg2schnitt Vanisch 4 4.329 12.11.2008, 20:17
Letzter Beitrag: targa
  Hallo, ich bin neu hier und habe ein Problem mit MPEG2Schnitt! weihe 3 2.479 21.05.2008, 08:56
Letzter Beitrag: weihe
  Fehler -113023 trotz Encoder?! icebaer1973 4 1.912 22.04.2008, 19:43
Letzter Beitrag: Martin

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste