Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Nachbearbeitung unter OS X (Abschlussbefehl)
#1
Ich hatte Schwierigkeiten, einen vernünftigen Abschlussbefehl zu erstellen.

/pfad/zu/meinem/shellscript "?0"

Liefert Fehler. Wenn die Datei z.B. /Users/skeeve/Wickie und die starken Männer 1.ts ist, kommt als erster Parameter beim Shellscript an:
"/Users/skeeve/Wickie

Das Problem ist meiner Meinung nach diese Zeile im Source:

Code:
Process subprocess = Runtime.getRuntime().exec(commandline); // anyone has told that works better

Die auskommentierte Folgezeile ist besser:
Code:
Process subprocess = Runtime.getRuntime().exec(arguments);

Zumindest läuft mein Shellscript jetzt und der Übergabeparameter muß auch nicht gequotet werden.

/pfad/zu/meinem/shellscript ?0


steht da also jetzt, und das Shellscript hat den Inhalt:

Code:
#!/bin/sh
infile=$1
outfile=$1.mp4
/Applications/iSquint.app/Contents/Resources/ffmpeg \
-y              \
-threads 4      \
-i "$infile"    \
-s 400x300      \
-r 25.00        \
-vcodec mpeg4   \
-g 300          \
-aspect 400:300 \
-b 2300         \
-async 50       \
-acodec aac     \
-ar 44100       \
-ac 2           \
-ab 128         \
"$outfile"
Zitieren
#2
Und hier jetzt nochmal der vollständige Abschlußbefehl, den ich in OS X nutze, um nach dem Schneiden und Konvertieren mein Aufnahmen vom M750S direkt eine iPod kompatible Version zu erstellen.

Hier die Variante für 4:3 Aufnahmen:
Code:
#!/bin/sh
osascript -e '
    property resH      : "400"
    property resV      : "300"
    property framerate : "25.00"
    property aspect    : "4:3"
    property bgcol     : {16705, 26985, 43690} -- kind of blue
    property fgcol     : {65535, 65535, 39321} -- kind of yellow
    property bdcol     : {65535, 65535, 65535} -- white
    on run (arg)
        set arg to quoted form of (arg as text)
        set columns to 26 + length of arg
        if columns > 200 then set columns to 200
        tell application "Terminal"
            set theTab to do script "/Applications/iSquint.app/Contents/Resources/ffmpeg -y -threads 4 -i " & arg & " -s " & resH & "x" & resV & " -r " & framerate & " -vcodec mpeg4 -g 300 -aspect " & aspect & " -b 2300 -async 50 -acodec aac -ar 44100 -ac 2 -ab 128 " & arg & ".mp4 ; exit"
            tell theTab to tell current settings
                if number of columns < columns then set number of columns to columns
                set background color to bgcol
                set cursor color to fgcol
                set normal text color to fgcol
                set bold text color to bdcol
            end tell
        end tell
    end run
' "$1"
Als Abschlußbefehl habe ich unter "TS" eingetragen:
Code:
/Users/skeeve/bin/convert2iPod_4x3.sh ?0
d.h. also, obiges Script muß als ausführbare Datei "convert2iPod_4x3.sh in meinem ~/bin Verzeichnis liegen.

Nach dem Konvertieren öffnet sich nun ein Terminal Fenster mit eigenen Farben (Siehe Properties im Script) in dem mit ffmpeg (aus iSquint) die Konvertierung erfolgt.
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  pX 0.91.0 unter Win7 nicht auf deutsch schluffen 2 1.500 01.09.2012, 08:36
Letzter Beitrag: schluffen
  Problem bei Installation unter Win7/64 Sixtus 2 1.635 26.01.2012, 10:06
Letzter Beitrag: Sixtus
  ProjectX unter Windows 7 x64 geht zwar - aber nicht richtig ... Waggerla 5 3.291 27.09.2010, 14:27
Letzter Beitrag: Waggerla
  CVS-Version von PJX unter Linux *edgar* 3 2.109 28.04.2010, 17:55
Letzter Beitrag: *edgar*
  Project X startet nur mit Admin-Rechten unter Windows7 bobkarl 12 9.539 16.04.2010, 18:41
Letzter Beitrag: Syncroniza
  TS zusammenfügen unter Vista x64 klappt nicht hompen 2 1.549 30.07.2009, 13:31
Letzter Beitrag: hompen
  Startprobleme unter Windows Vista Jeythor 4 1.694 20.07.2009, 22:46
Letzter Beitrag: Jeythor
  Einstellungen > Nachbearbeitung > Externe Programme? Wofür? Skeeve 2 1.250 17.04.2009, 22:37
Letzter Beitrag: Skeeve
  Priject X Nachbearbeitung startet m2s zweimal mdat 9 2.580 28.09.2008, 19:21
Letzter Beitrag: mdat
  Keine Reaktion einiger Buttons unter: Schnittsteuerung -> Navigation billie 11 2.918 07.09.2008, 22:10
Letzter Beitrag: billie

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste